CCPro - Incident - CCPro PCI Payments (BND1 + BND2) – Incident details

All systems operational

Service Status
To subscribe to this status page, please Contact Support
Or use our API to pull updates to a page of your own

Incident - CCPro PCI Payments (BND1 + BND2)

Resolved
Degraded performance
Started 1 day agoLasted about 3 hours

Affected

CCPro Contact Centre UK

Degraded performance from 9:30 AM to 12:11 PM

PCI Card Payment Platform

Degraded performance from 9:30 AM to 12:11 PM

Updates
  • Resolved
    Resolved

    The PCI providers have now rectified the fault and all payments should work as normal.
    No further updates are expected.

  • Identified
    Identified

    The issue has been identified and the PCI provider is working on a fix.

  • Investigating
    Investigating

    We have been made aware by our PCI provider of a technical issue which may impact your PCI Payment Service.

    Some users may experience difficulty taking payments.

    Engineering teams at the provider are investigating

    We will provide updates shortly.