CCPro - CCPro Contact Centre Call Jitter / Distortion – Incident details

All systems operational

Service Status
To subscribe to this status page, please Contact Support
Or use our API to pull updates to a page of your own

CCPro Contact Centre Call Jitter / Distortion

Resolved
Degraded performance
Started 5 days agoLasted about 15 hours

Affected

CCPro Contact Centre UK

Degraded performance from 12:56 AM to 3:55 PM

CCPro Contact Centre UK (BND1)

Degraded performance from 12:56 AM to 3:55 PM

CCPro Contact Centre UK (BND2)

Degraded performance from 12:56 AM to 3:55 PM

PCI Card Payment Platform

Degraded performance from 12:56 AM to 3:55 PM

Updates
  • Resolved
    UTC
    Resolved

    This issue should now be resolved.

    The network instability previously identified on the affected voice service path appears to have stabilised, and recent testing indicates a significant improvement in audio quality.

    Our engineering teams continue to monitor service performance closely and are working with our partner carriers to validate that the improvement is sustained. At this time, we have not received any new reports of audio degradation since monitoring commenced.

    No further updates are planned unless further issues come to light.

  • Update
    UTC
    Update

    Our investigation has identified intermittent packet loss and instability affecting a network transit path between our platform and Microsoft services. Analysis performed with our upstream transit provider has identified packet loss and route instability impacting a Microsoft IP transit connection, which may result in some agents experiencing robotic or degraded audio during calls.

    We are actively working with the upstream provider and Microsoft to monitor the affected path and implement corrective actions. Service availability remains unaffected; however, a subset of calls may continue to experience intermittent audio quality issues whilst remediation efforts are underway.

  • Identified
    UTC
    Identified

    We are actively working with the upstream provider to monitor the affected path and implement corrective actions. Service availability remains unaffected; however, a subset of calls may continue to experience intermittent audio quality issues whilst remediation efforts are underway.

    Impact: Some contact centre agents may experience intermittent robotic, distorted, or degraded audio during live calls.

  • Investigating
    UTC
    Investigating

    We are investigating reports of intermittent degraded call quality affecting a subset of contact centre agents. Agents may experience robotic or distorted audio during active calls, while call functionality remains available.

    Our engineering teams are actively investigating the issue and reviewing all service components. We will provide further updates as more information becomes available.

    Impact: Some agents may experience intermittent robotic or degraded audio quality during calls.

    Status: Investigation in progress.